We received confirmation that all service are now operational. If you continue to experience issues, please contact our customer support team.
Thank you
Posted Jan 23, 2025 - 19:38 EST
Update
Our engineers are still working towards a resolution with Oracle Cloud. We will continue to keep you updated. We apologize for any inconvenience this may cause.
Posted Jan 23, 2025 - 19:16 EST
Update
The VoIP engineers are still working on these issues. Click to Dial may be impacted; however, manual inbound and outbound dialing should still be working. We will continue to update as they become available. Thank you for your patience and understanding.
Posted Jan 23, 2025 - 17:42 EST
Investigating
Our VoIP engineers are currently investigating an issue with Oracle Cloud affecting some of our Clarity services since around 4:20 PM EST (21:20 GMT). Some inbound and outbound calls may be impacted as a result of this outage. Some may also be experiencing "Failed to Establish" when attempting to place an outbound call. Our Engineering Team is currently working with the provider to bring the services back online.