The inbound dialing and quality issues are now resolved. Thank you for your patience and understanding.
Posted Oct 13, 2025 - 11:13 EDT
Monitoring
Our engineers have identified and resolved the inbound call issues. We will continue to monitor. If you are still encountering issues, please contact the Customer Support Team.
Posted Oct 13, 2025 - 11:01 EDT
Investigating
We are investigating reports that some clients may be experiencing an issue affecting inbound calls with one of our carriers. Our team is actively investigating the cause and working with the carrier to resolve this as quickly as possible.
Impact: This may result in abnormal delays or an inability to receive inbound calls for some users. Some call quality issues may also be present
We will provide an update as soon as more information becomes available. If you have any questions or concerns, please reach out the Customer Support Team.